• Hello Guest, welcome to the initial stages of our new platform!
    You can find some additional information about where we are in the process of migrating the board and setting up our new software here

    Thank you for being a part of our community!

1992+ 740/940 Instrument Cluster Repair!

Janspeed

Active member
Joined
Sep 5, 2005
Im diggin up this thread because, my cousin has a 95 940 that some of the cluster lights don't come on, but if he floors the pedal they will light up and stay lit till he turns the car off, when he goes to turn it on, same thing no lights, floors the gas, lights come on...
any idea what this might be?

gaspedal assembly hitting a hanging part of the wiring loom ?

Also his warning light that says a bulb is burned out is forever on, but no bulbs are out, however, his car eats brake light bulbs...

is he using the correct wattage bulbs in the brakelights?
my 940 has a 3rd brakelight and i have installed an additional brakelight in the spoiler. I hooked it up to one of the existing brakelights and now every time i brake the yellow bulb failure light comes on. in other words: the error light is sensitive to how many and what kind of bukbs you install.
 

Anatoli

New member
Joined
Sep 17, 2007
Location
NoCO
gaspedal assembly hitting a hanging part of the wiring loom ?



is he using the correct wattage bulbs in the brakelights?
my 940 has a 3rd brakelight and i have installed an additional brakelight in the spoiler. I hooked it up to one of the existing brakelights and now every time i brake the yellow bulb failure light comes on. in other words: the error light is sensitive to how many and what kind of bukbs you install.

i have the same setup: third brake light + a honda prelude spoiler with a diode brake light.
I sometimes get these "bulb out" warnings for a few pushes of the brake pedal once in a while.
 

gpl1968

New member
Joined
Jul 20, 2009
Location
Wirral UK
The bulb-failure warning device works on the resistance in the circuit, lighting the warning bulb when the preset resistance is not met or exceeded.
You could try using a small relay to switch the extra brake light bulb, taking power from a separate fused circuit.
 

760TurboChick

New member
Joined
Jun 23, 2009
Location
Waynesboro, VA
Dude, YOU ARE MY HERO! I posted about my SRS light about 2 or so weeks ago...this just may be the problem...and it's so helpful that you posted this. I am going to tear into it soon and see if that's what's been puzzling me! Thanks again! :)
 

byte1032

New member
Joined
Apr 6, 2004
Location
Roller coaster road SW of PDX OR
grumble........... tightened things on my cluster and had a possible positive result but the srs light stayed on which it had been doing before since my issue went full scale. drove it for about .5 miles and the cluster stopped working except the temp gauge when the OD light was light (only light that was on). swapped to another cluster and all seems normal but srs light staying on again. any input is greatly needed.....
 

tiredoldtommy

Active member
Joined
Mar 1, 2008
Location
Antlers, OK
Could this article also apply to an '86 760ti? Mine's got the fuel gauge problem intermittently, and some times I can thump it with my finger and it will work.
 

gear whine

advocate of k-jet
Joined
Dec 17, 2006
Location
18452, NEPA
Matt,

I've looked at this thread for years and I've never really taken the time to actually DO IT.

'91 745T, the daily
My speedo/odometer doesn't work at all, anymore. And more ridiculously my fuel gauge is stuck @ 1/3 of tank. Well, I'm tired of not having working gauges for OVER 2 YEARS now, so something needs to happen.

A couple of buddies are coming up to my house thursday night before Carlisle, one of which is a decent solderer...
If it doesnt work I don't care I have no more options.

About the speedo...I've tried 3 different sensors, none of which do anything different. The ENTIRE wiring harness from the sensor all the way into the side rear cargo cubbies, no splices. entire harness replaced. nothing.
Fall of 2008 I lost the function of the speedo/odometer....
It would be working normally then it would drop to 0 and then back up to speed. It did this several times before coming to a hault and never working again. I'm think this re-solder thingy is going to work.
But I've tried other clusters but no worky. hrrmm....

As for the fuel gauge it just went to 1/3 tank and that was it. It always worked fine and then it didn't. Simple as that.
However, the fuel warning light still works. heh

Oh well, I'll let you know how it goes when I see you at Carlisle.


By the way though, GREAT WRITEUP. EXCELLENT!
 
Last edited:

thelocalspoke

Member
Joined
Jun 6, 2007
Location
Right here
Gonna chime in with an addition to this. If you've got a 7/9xx, and typically bad control arm bushings (the big ones)on the rear end, the speed sensor in the diff cover can make contact with the Panhard rod. This'll eventually damage the wiring, plug or maybe even the sensor. It MIGHT even blow that fusible link in the cluster, though I haven't verified that. Mine had frayed wires on the sensor plug and a blown link.
 

bennyg

New member
Joined
Oct 22, 2010
Location
Hi plains Big WindyWHY-Ohh
1992 Gauge cluster Complete unit question or trade ?

Will a 1992 940 non -turbo gauge cluster ,fit in my 1994 non-turbo 940? I have read a little on the clock/fuel gauge mods ...however

This car displays an odd characteristic , The SRS light will stay on , and in short order drain the electrical system ...However ,this is the strange part , If I strike the top of the dash, often times fairly hard ,it will go out ,and you can hear the electrical system i.e. alternator kicks from discharge mode to charge mode .I discovered this by driving with the light on ,and then hitting a bump!This has driven me nuts for a long time , I know there is alot of potential for SRS light errors , but for the life of me I think its in the cluster , and the cluster needs replacing , Therefore as my original question pondered , will the early cluster work ,and/or does anyone have a friend of a friend who has a 94 gauge cluster to swap ? I know this is an old thread but would GREATLY appreciate my fellow Volvo fanatixz input Thanxz Sincerely Ben
 

Quinnn

New member
Joined
Jul 3, 2017
Location
Virginia
Will a 1992 940 non -turbo gauge cluster ,fit in my 1994 non-turbo 940? I have read a little on the clock/fuel gauge mods ...however

This car displays an odd characteristic , The SRS light will stay on , and in short order drain the electrical system ...However ,this is the strange part , If I strike the top of the dash, often times fairly hard ,it will go out ,and you can hear the electrical system i.e. alternator kicks from discharge mode to charge mode .I discovered this by driving with the light on ,and then hitting a bump!This has driven me nuts for a long time , I know there is alot of potential for SRS light errors , but for the life of me I think its in the cluster , and the cluster needs replacing , Therefore as my original question pondered , will the early cluster work ,and/or does anyone have a friend of a friend who has a 94 gauge cluster to swap ? I know this is an old thread but would GREATLY appreciate my fellow Volvo fanatixz input Thanxz Sincerely Ben


I'm currently doing the opposite of yours, I'm swapping a 1994 into my 1992.

They should be identical, except your fuel gauge will not work. Otherwise it should just plug right in.

You have to either replace your fuel pump sender with a 92, or swap your old fuel gauge into the 92 cluster, as I understand it.
 
Top