• Hello Guest, welcome to the initial stages of our new platform!
    You can find some additional information about where we are in the process of migrating the board and setting up our new software here

    Thank you for being a part of our community!

1994 945 Turbo Ultimate DD Build

Made a prototype bezel for the display out of some kydex. Eventually I'll have my brother design and 3D print one that fits the space exactly.

l8qmEMJ.jpg
 
Last edited:
The UTCOMP Pro is a pretty sweet setup for the money. It was less than $250 including a Bosch 3-bar map sensor for the boost display. It will display speed, RPM, fuel econ, acceleration times, braking times, reads almost any analog gauge, datalogger with android app, input for 4 digital temp sensors (includes 2x DS18B20). I'm sure I'm forgetting some features.

https://www.reveltronics.com/en/sho...al-trip-computer-utcomp/utcomp-pro-kit-detail

The only gripes I have with the system is that the date can only be displayed in DD/MM/YYYY and the clock is 24H format. I reached out to the owner and requested fixes for that in a future update, fingers crossed.

You'll want a wiring diagram for your car when you install this as I needed to tap into the signal wires for the VSS, injector pulse (used to calculate fuel econ and RPM), coolant temp, headlight power, 12v constant, 12v ignition, etc.

I use positaps for stuff like this so they can be easily removed without damaged to the orignal harness if I ever want to do something else. I used the red ones with gray ends, but this is how they work
posi-taps-2.jpg



Tapping wires behind the cluster for coolant temp and a headlight signal

WYQaKP4.jpg


I installed the map sensor under the dash on the driver side and tee'd into the hose for the factory boost gauge. Ziptied to the big harness to the EZK

9qfM1GF.jpg
 
Here are the DS18B20 temp sensors included with the reveltronics kit. They can handle temps up to 125C but they need to be waterproofed. Reveltronics recommended soldering each leg and heat shrinking, then heat shrinking the entire sensor, leaving about 1/4 of the sensor exposed.

I am using the original gauge temp sensor for coolant temp and I have an OEM ambient temp sensor kit ready for the car, so I decided to mount one these in the airbox before the MAF and the other in the cold side pipe right before the intake elbow. I drilled holes and glued the sensors in place with FIPG.

Surprisingly the original intercooler does pretty well! I don't think I've seen a temp difference more than 20 degrees, and it's usually less than 15 during normal driving.

RF3oPYB.jpg

ldZqDcw.jpg

r7lHMgr.jpg
 
And here it is all installed! The kit includes a mini circuit board with 3 momentary switches to control the screen, which I mounted on the radio bezel below the preset buttons.

For an even sleeker look, I had considered tearing the radio apart and using the 4/5/6 buttons to control the gauge.

rRm0IgF.jpg

DdSdgX7.jpg


I've also taken almost 2.5 seconds off the original 0-60 time. (ignore the other numbers :-P) You can program the gauge for whatever acceleration times you want. It will also display braking times of your choosing.

tPKyr3W.jpg
 
I wanted to get my injectors cleaned so I took the opportunity to clean my intake manifold inside and out at the same time. The yellowed injector seemed to be very slowly leaking at the o-ring and discolored the plastic. My local tuner shop has injection cleaning machines and it only cost $40+tax. Took about a week.

Np84rMb.jpg

MG6xZO2.jpg

15mMzJG.jpg

zcqggL6.jpg


The shop told me the were extremely dirty but cleaned up nicely!
 
I also polished my throttle pulley and painted the brackets gold to try to duplicate the original plating, but I'm not thrilled with it. Does anyone have experience with getting small parts replated? I may just have all of the underhood brackets plated in yellow cad/zinc eventually.

sAqnUYg.jpg

U14kZFY.jpg
 
Clean install on the UTCOMP Pro - I've got one installed in my 945 as well. What did you use for the VSS on yours? Is that picked up from the LH2.4 inputs? If so, was there anything special in the configuration you had to do in order to get the correct settings? I hooked up injector pulse, RPM and perhaps something else from there but didn't even think about picking up the speed signal! It's fed from the gauge cluster to the ECU, right?
 
Clean install on the UTCOMP Pro - I've got one installed in my 945 as well. What did you use for the VSS on yours? Is that picked up from the LH2.4 inputs? If so, was there anything special in the configuration you had to do in order to get the correct settings? I hooked up injector pulse, RPM and perhaps something else from there but didn't even think about picking up the speed signal! It's fed from the gauge cluster to the ECU, right?

Thanks!
Yep, there's a speedo wire to the ECU. I don't recall which wire it was though.

For VSS calibration you drive the car for a known distance and input that distance in the utcomp software. If you download the latest user manual from reveltronics it's on page 26-27
 
Thanks!
Yep, there's a speedo wire to the ECU. I don't recall which wire it was though.

For VSS calibration you drive the car for a known distance and input that distance in the utcomp software. If you download the latest user manual from reveltronics it's on page 26-27

D'oh, I'd almost forgotten that it was a very similar process for calibrating the injectors. Thanks :) Now to dig up which pin on LH2.4 that is! My speedo has been intermittently dying recently so I'm gonna have to fix that as well..
 
D'oh, I'd almost forgotten that it was a very similar process for calibrating the injectors. Thanks :) Now to dig up which pin on LH2.4 that is! My speedo has been intermittently dying recently so I'm gonna have to fix that as well..

Check your wires to the VSS on the diff, I've had those break before and it would be intermittent
 
Check your wires to the VSS on the diff, I've had those break before and it would be intermittent

I am going to redo my diff harness again, this time stopping trying to splice the Volvo one.

Looking at the body work you did, I am very impressed. I wish I knew anything about prepping and waxing a car so mine would not have been so damaged by Florida sun.
 
Were did you get that foam you put on the wheels well covers? sounds like I need to do that to my 740

It's Siless brand 157mil closed cell foam. They sell it on amazon and ebay.

I think all the brands are similar, just make sure its non-absorbent, closed cell foam so it doesn't hold moisture.
 
It's about time to update this thread to replace what was lost in the great TB outage. Text will be brief but feel free to ask questions!

Painted all of my belt mouldings and wiper arms with SEM ultra trim black and a satin 2k clearcoat

hdiY6YAl.jpg


S1IAtoMl.jpg


z7Lp5lZl.jpg


qcVwHwxl.jpg


Also replaced the cowl screen mesh (stainless mesh, painted black) and clean/painted the inside of the cowl to make it less visible.

F7nVVhrl.jpg


iP2DasYl.jpg


TscdhbDl.jpg
 
built a 3 inch stainless exhaust with a 3" cat. I will finish with a 3" downpipe and ball joint at the cat-dp junction when I replace the turbo with an angled flange td04hl. Painted the rear muffler black with some VHT so it's less visible.

vkiJCz1l.jpg


OiNy5Zul.jpg


0nSBc2il.jpg


PF1Qvbdl.jpg


pb3oN8Zl.jpg
 
Last edited:
E85 time. Tested my local supply and it's typically about 70% ethanol. 55lb injectors (which were ultimately too big for the 13c and I was getting rich misfires @ 14psi)

72T2Q3dl.jpg


M3tDFiRl.jpg
 
In an effort to fix the rich misfire I loaded up the parts cannon. Replaced the coil (with a sweet NOS bosch coil), O2 sensor (original one was looking pretty ragged), and tried different plugs and gaps (BR7ES plugs helped but didn't eliminate the problem entirely).

dgL3nlYl.jpg


UAkzYXfl.jpg


hJAGzmbl.jpg


Also did a boost leak test, didn't find anything significant, just a bit of bubbling from the evap check valve and EGR valve.

jSkhXG7l.jpg


IZapybKl.jpg


h3S9IjYl.jpg
 
V90 armrest install. Foam tape was added on the lip of the console to keep it from squeaking/rattling

QCqPvSPl.jpg


2WBFQcnl.jpg


GK1cyxxl.jpg


5SgUEA9l.jpg
 
Made a mounting bracket for the NXS boost controller and finished some seat belt caps my brother 3D printed for me.

x4vqt80l.jpg


44uAqzll.jpg


z6JOjksl.jpg


g2vQZLYl.jpg


NRX2tRAl.jpg
 
FIXED THE RICH MISFIRE

The ECU was able to adapt to the 55lb injectors on E85 just fine out of boost, but it went way too rich in boost (even with a custom chip from RBP). Swapped in some green giants from an S60R, bypassed the resistor pack, and now it runs great!

The green giants are probably the smallest injector you'd want to run with E85, but they might work for running 93 gas without swapping injectors again (after an ECU reset).

tZoTYV9l.jpg


HCoPVeal.jpg


Bonus hack for 7/9 owners for draining the rail

WcBUGoPl.jpg


EZK mod done for a bit of timing advance on the corn

83W275cl.jpg
 
Back
Top