• Hello Guest, welcome to the initial stages of our new platform!
    You can find some additional information about where we are in the process of migrating the board and setting up our new software here

    Thank you for being a part of our community!

Henry's 764ti build thread (56k get dsl)

urbanwheeler

Active member
Joined
Mar 1, 2008
Location
Santa Cruz, CA
To start this off, this car was Orie's car at one point, then his friend owned it (the guy I got it from). He had it sitting in his driveway with a broken clutch fork and 2 damaged Dracos, missing parts on the steering column, and a ton of other little things I will sort as it comes along. Welded up the hole in the clutch fork, bled the slave cylinder, put 2 borrowed rims on, and it was "roadworthy" enough to get home

What it looked like when I first got it home (drove it open turbo at 2am the 86 miles home, as the previous owner wanted the 3" exhaust it had)

<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSC_1654.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSC_1654.jpg" border="0" alt="Photobucket"></a>

<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSC_1657.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSC_1657.jpg" border="0" alt="Photobucket"></a>

Rare plastic piece that goes in between the tail lights
<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSC_1656.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSC_1656.jpg" border="0" alt="Photobucket"></a>

<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSC_1655.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSC_1655.jpg" border="0" alt="Photobucket"></a>

Note the lack of down pipe. It sounded really cool though, and angered the neighborhood prick:lol:
<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSC_1667.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSC_1667.jpg" border="0" alt="Photobucket"></a>

The clutch fork repair I did. I ultimately fixed it with a brass acorn nut
<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSCF1433.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSCF1433.jpg" border="0" alt="Photobucket"></a>

Electrical repairs
<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSCF1432.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSCF1432.jpg" border="0" alt="Photobucket"></a>
 
I love this car. My first turbo. First car i bought myself. Second volvo. I'm so glad she's not in a pick n pull lot.

Even though it's ugly, most of the stuff that was needed to keep it running really well was done. So it's a great sleeper. :-D
 
Put the 940 turbo exhaust on, but have to make the rear mount for the 2nd muffler and the s curve pipe. The interior is an ugly mix of black and faded red parts. The red parts don't look too bad, but it looks strange with black front door cards, but red a pillar covers, rear door cards, and everything else other than the black front seats, back seats, and center console. I am also gonna have to get rid of the smell it has going when it sits in the sun.
 
Registered it yesterday:-D

Sorting some of its things. The gas gauge doesn't work, the front brakes pull the the right (like one caliper is seized or something, but brakes in a straight line if the brakes are really applied).

Also, the automatic climate control melted part of the fusebox around the 30 amp blower motor fuse, so I think its time for manual heater controls once I can find/afford one. Other than that, it runs good. I need to get 2 more rims, or maybe some steelies. Things are gonna be kinda tight till I can find a job, or sell some stuff, so it might take a while.
 
You need 2 Dracos?

What do you have on it right now?

I have 2 dracos in the front, and 2 borrowed 10 spokes (745turbogreasel loaned them to me) on 205/60r15s in the rear. I have tires, the ones off the damaged dracos(195/60R15), and then a couple 205/60R15s off a friends sisters car.
 
Installing the rear muffler, since I am getting tired of the loudness. And its almost polizei maximum revenue generation weekend. Don't want no unwanted attention.
 
Registered it yesterday:-D

Sorting some of its things. The gas gauge doesn't work, the front brakes pull the the right (like one caliper is seized or something, but brakes in a straight line if the brakes are really applied).

Also, the automatic climate control melted part of the fusebox around the 30 amp blower motor fuse, so I think its time for manual heater controls once I can find/afford one. Other than that, it runs good. I need to get 2 more rims, or maybe some steelies. Things are gonna be kinda tight till I can find a job, or sell some stuff, so it might take a while.

My gas gauge likes to stick, if I knock on the cluster hard a few times it starts working fine; go figure. You might try that.
 
My gas gauge likes to stick, if I knock on the cluster hard a few times it starts working fine; go figure. You might try that.

I'll try that. I had the cluster apart, since it has a ton of dirt/dust in it, and all the connections looked good. The voltmeter now works good, but the gas gauge doesn't work at all now (so I drive around with a 5 gallon gas can in the passenger footwell, since I don't know what kind of mpg's it gets)

I also need to fix the overdrive electrical asap since 95% of my driving is freeway.


And get another jack:

<a href="http://s10.photobucket.com/albums/a107/posbox/?action=view&current=DSCF1460.jpg" target="_blank"><img src="http://i10.photobucket.com/albums/a107/posbox/DSCF1460.jpg" border="0" alt="Photobucket"></a>

Thing toppled over while I was lifting the back of the car to remove the jackstand. Now I have no jack to keep in the car.
 
Back
Top