• Hello Guest, welcome to the initial stages of our new platform!
    You can find some additional information about where we are in the process of migrating the board and setting up our new software here

    Thank you for being a part of our community!

MS 2 not functioning


Active member
May 27, 2017
Eldorado Springs Mo.
My car set for 8-10 weeks, I went to start it and it would run for 2-3 seconds then die. I decided to plug my computer in and install a gas tune. Been running it on e85 and have put a few gallons of gas in it to get me to the station. Well when I plug computer in to MS2 it doesnt connect. Its says offline on the main screen and in the bottom left it says "Error reading from D2XX will try and reopen."

So I grab one of my old cords and tried it, says same thing. I will admit that the MS2 on and off switch was left on. Which mean is was left on for 8-10 weeks. Im kinda stumped at the point. As far as I can tell fuel pump kicks on but dont have any fire after the 2-3 seconds. At this point its not doing anything at all just cranks. Im gonna recheck everything in the morning but believe nothing has been unpluged etc. If Ive burning up ECU no biggy and lesson learned.
Got another set of plugs to put in it?

Can you jump 12v and ground to the ms to see if it connects to a pc?
yes I will try that in the moring. I do get a red and flashing green light at the plug in of MS2. I have a tablet with tuner studio, I wlll try it too in the morning. thanks
well this morning I tried all of above. No change, reading toubleshooting guide now but think Ive tried everything. Never heard of a MS2 going south. But guess first tme for everything.?
If your MS2 is traditional, i.e. you haven't switched to sequential operation, you should have the 3 LEDs on the back of the case. As I recall, on a cold engine the warm up LED should illuminate on power up and when you crank the engine the injector lights should flash. If you don't get any LED activity then check the power supply to the MS2 DB37 to make sure that it is OK. If you have external power, then time to pop the case open. The first thing would be to check that you have 12 v to the regulator input and that you have 5 v on the sanctioned 5 v. If you don't have 5 v on the sanctioned output the poly fuse may have failed. You can find the schematics for the MS2 board here:


It is unlikely that you have damaged the actual micro controller chip.

If the LEDs power up then you may have a serial bus communications failure. My favorite pick would be a dead USB-RS2 adapter. However, make sure the COM ports are correct and that the driver for the adapter has not been corrupted or is no longer present.

The red / green flashing lights - is that on the RS2 - USB adapter because I don't ever recall seeing red/green lights on an MS2 board. Are you using an FTDI based RS2-USB adapter? Those are the most reliable.
I have the microsquirt a newer one. Sorry which I believe has MS2 firmware. If I remember correctly. I have no fire at plugs wire. Im just running the single coil with dist. I did have fire once but went away, weird deal. I do have good power to the MS and good ground. The red and green lights flashing light are where the RS2 adaapter plugs in.
Well its fixed; after troubleshooting everything, I remembered I moved the Map sensor. I had the plug on it upside down. I flipped it over and bam everything started working. I appreciate all the help, Ive learned more about the MS through all this.