• Hello Guest, welcome to the initial stages of our new platform!
    You can find some additional information about where we are in the process of migrating the board and setting up our new software here

    Thank you for being a part of our community!

redblockpowered converts from 240 to 940

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
Hello folks. Long time listener, first time caller, I'm a 19 year old engineering student and a month ago I bought my first car, a 1993 944 Turbo. Prior to that I shared my dad's (shoestring on here, of cam timing measurement fame) 245 and raced a 245 in 24 Hours of LeMons as a part of Swedish Mafia Racing. Seeing the durability and simple design of the 240 over the course of years of endurance racing got me hooked on these cars, although I had originally wanted a SAAB 9000 for my first car to try and break the mold a little bit. Months of searching coupled with New England rust and the absurd devotion of SAAB owners made it clear that that wasn't going to happen.

After quite a bit of frustration looking for a turbocharged car with a manual transmission, I decided that it wouldn't be too big of a deal to try and manual swap a car that was hard to find in manual form, or not available configured as such in the US. Considering the help and spare parts I'd be able to steal/share with my dad as well as the relatively competent rustproofing the 940 seemed like a somewhat obvious choice. I settled on an M90 due to the swap being bolt-in, the peace of mind at higher power levels (vs. M47), and the ability to use 100% OE components. Now, I just needed to find a source for a transmission and a decent car to use as a starting point. I trolled craigslist and Facebook Marketplace for about a month before finding this fabulous machine:

vTyCTGEl.jpg


es8BhWel.jpg


Listed at $1400 and with somewhat dubious pictures, I headed down to Fairhaven, MA with my dad to look at this thing. The things I learned over the course of our examination of the car were as follows:

It worked.
The owner turned out to be sixteen years old and had been driving it every day with an expired inspection.
The body was straight and pretty rust-free.
It had some standard 16-year-old MODZ like terrible window tint, yellow fog light covers (which I actually liked please don't judge), and an eBay-spec manual boost controller.
Half of the exhaust fell off and the front sway bar was disconnected.
We didn't look inside the car. Oops.

I threw out a $1000 offer for ****s and giggles and he took it. The next week, we took two Virgos off of the 245 to replace the very destroyed rear tires along with some other miscellaneous spares down to Fairhaven and attempted to limp the car back home to Swampscott.

UMXxD1yl.jpg


forgot to mention it's a SLAYER EDITION 940 \m/

With the Virgos in the rear, the car made it 70 miles just fine, with my dad (driving the car for safety/insurance reasons) speaking highly of its smoothness. Following it in my mom's BMW I noticed an astounding amount of body roll and a sagging left rear spring but not much else.

At home, a few of the dark secrets of the car were revealed including crumbly brake hoses, a busted power seat, an interior that smelled of cigarettes, and most unfortunately a cracked rear window hidden by the very illegal window tint. With the car at home, job 1 was to get the car ready for the rather strict MA state inspection.
 
Last edited:

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
I don't really have much in the way of pictures of what happened immediately after purchase but the front swaybar was mounted with new endlinks, the brake hoses were changed, I peeled off the window tint, new Kumhos were mounted and balanced, and quite a few extremely sketchy coolant and vacuum hoses were swapped out. The tint came off way easier than expected but the adhesive is really on there. Foamy window cleaner and a razor blade seem to do the trick although the combination looks and feels like snot.

jpYPav0l.jpg


The foglight covers had to go for inspection and the window tint came off because it was awful. A cracked headlight was spotted, and I replaced the reflectorless left front indicator with a decent one from supreme940 who also supplied a new in box Starla exhaust system and a downpipe since someone had cut mine for a cat delete. I shelled out for a new cat because I like the Earth.

iyR1dtDl.jpg


Cleaning out the inside of this thing revealed quite a few goodies, including some illegal fireworks and several knives as well as many receipts and the title to a 1973 Yamaha CT-1. I pulled out the front seats and attacked the car with a Shop-Vac while my dad got to the difficult job of replacing the middle right power seat cable, which seems to be the only one that fails as it is the only one you can still get from Volvo. Before and after the vacuuming:

jMepIsll.jpg


SnYKjzFl.jpg


I threw out the AutoZone floormats that it had almost immediately, in addition to deleting the MBC. Volvo mats are in the mail in addition to map pockets and speaker grills. Recently having arrived in the mail from the UK is this thing:

GyE9OtFl.jpg
 
Last edited:

thessejway

¯\_( ͡❛ ͜ʖ ͡&#100
Joined
Dec 10, 2015
Location
Toronto, Ontario, Canada
Awesome work
You're gonna love that car

I too am going for swapping a manual trans into a 940. How hard was it to find an M90? I've been leaning towards a B&W T5 because I figured it wasn't worth trying to find an M90 in North America
 

dl242gt

Old and boxy but good.
Joined
Jun 21, 2002
Location
S NJ, a suburb of Phila.
He bought the M90 from the area of the world where people can supply one. If you can do it. It is a nice option for a manual swap. Should drive really nice with the swap.
 

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
Awesome work
You're gonna love that car

I too am going for swapping a manual trans into a 940. How hard was it to find an M90? I've been leaning towards a B&W T5 because I figured it wasn't worth trying to find an M90 in North America

It wasn't so bad. I got mine from Classic Swede in the UK, Dai was awesome throughout the whole process and the price was very reasonable (less than the car including freight) although getting one from the UK does mean you need to get a LHD clutch/brake pedal or just cut your brake pedal like I plan on doing. I still need to order my clutch disc and source a dog dish flywheel. The T5 has much more performance-oriented ratios but is also quite loud from what I've heard in addition to not being designed to fit in a 940.

I've seen little pilot bearing area spacers for the M90 used with a flat flywheel to approximate the thickness of the original dual-mass flywheel, does anyone know if I need one with a dog dish flywheel as well?

From Anthony Hyde: "Another issue is the length of the mainshaft - Initially the box mates to a thick dual mass flywheel (expensive), BUT if used with a Volvo flat flywheel the input shaft is not long enough to fit into the crank pilot bearing. An adaptor would be required, more info when a fix comes to light."

Low/uneven idle (resulting in stalling on the road) troubleshooting resulted in the discovery of a tear in the CBV diaphragm. Replaced the CBV with one off of a 15G I got on Craigslist, idle is normal now as far as I can tell. It's tough to troubleshoot the stalling without an inspection and that's a few days away. This car idles so much smoother than the 245 with the A cam, which rumbles like a cammed V8 until it comes up to temp.

Then to bring us up to speed (I don't have pictures of this stuff so I'll just run right through it real quick) I cleaned out the IAC, the car developed a bunch of strange drivability issues and then threw an AMM code so I replaced it with our spare and bought a reman AMM from a guy on Craigslist for $35 as well as a gold EZK, which I'm not sure I plan on keeping. My dad made a brake line bracket for the left rear since the one that was there had rotted in half. The car had a fuel leak which was eventually determined to be caused by a pinhole in the fuel pump banjo fitting. The pump that's on the car now is very loud and unpleasant, but it works so I'm not sure how far down the to-do list it should be. Anyway, I pulled the cluster out and found a cracked joint, redid that and fixed a few others that were looking a bit dubious and now the fuel gauge works as intended.

undCxHtl.jpg


Here's how it looked for a while when I was at school and couldn't do anything:

3oECzaHl.jpg


Seeing as we've lived in this house for not more than two months I'm sure our new neighbors were excited to see a 940 on jackstands in the driveway.

And here's how it looks now!

YOHJ1T0l.jpg
 
Last edited:

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
The car is finally inspected and legal! Stalling issue is fixed with the new CBV, and my dad blew the vacuum line off of the heater controls. The guy who inspected the car noted a "loose tie rod" but what that means exactly will have to be investigated. Map pockets are here and I need to order some M90 stuff from Sweden but I've been quite busy with school. Oh, and it'd be nice to actually wash the outside of the car at some point.
 

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
Finally drove the damn thing for a reasonable amount of time, took it to New Hampshire for the Lemons race there and it was mostly trouble-free. The idle is still pretty strange and inconsistent, the car generally idles high if you put it in park while hot (soon enough the car won't have park and this will no longer be an issue), it will occasionally crank for a while before starting (hardly a big deal, waiting for the pump to prime mostly corrects this one) and most amusingly, my driver's side turn signal blew off at speed on I-93.

dUTDzg0.jpg

Have you seen me?

I got up at 5ish Monday morning to drive to eEuroparts in Connecticut and get a decent new one rather than another used one with delicate ancient plastic tabs that fly off if you look at them funny. Made it out of school's commuter lot before I got towed, got a decent turn signal, and made it back home in time for my first class of the day so I'd call it mission accomplished. I got about 22 miles per gallon in the ~800 miles I covered last weekend which is a little better than expected, but then again I was mostly on the highway and also making a sort-of deliberate effort to be economical.

2oVnXqc.jpg

The car barely features here but it's nice to include pics to try and attract those clicks

PROBLEMS:
There's a little bit of wheel shake at speed and the initial bite on the brakes is really pretty subpar. It doesn't negatively impact my confidence while driving but I would like it to bite a little more. Maybe I've been spoiled by the Hawk pads in the 240. The driver's window makes a horrible noise when fully lowered, as if it wants to keep going down but obviously that's not possible. The door card will have to come off at some point to look at that but work is gonna slow down on this thing as it starts to get unpleasant outside here in Massachusetts. The vacuum lines and the grounds could use some attention/cleaning/replacement but overall I'm pretty happy with the car's performance. It's not very fast but it's comfortable and has good bones as the hosts of an HGTV show would say.
 
Last edited:

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
VZx20s0l.jpg


BIG UPDATE: The transmission is in! Lots to write about now. I'll do a full writeup on the swap later but let's start catching up. I've done some 1500 miles since the swap and I'm really enjoying the car so far. In March it went up in the air to get swapped, two weekends worth of work turned into a little over two months thanks to some astonishing levels of rain here in Massachusetts, my schoolwork, and entering crunch time for my school's FSAE team. The M90 suits the character of the car a lot better than I think a T5 would (comfy ratios and shift action vs. those more suited to racing-type behavior). An unexpected benefit is that I've been seeing some 24-25 combined MPG out of the 940 since it was swapped, even now that I've turned the boost up with a GFB G-Force 2 boost controller. I think it would benefit from the factory 3.31 or 3.54 ring and pinion vs. the AW71's 3.73 but there's plenty to do with the car before that really even comes up on my radar. My dad and I have made a ton of progress on this car troubleshooting its numerous issues thanks to years of prior neglect, and over the course of the swap nearly everything in the drivetrain area was rebuilt/replaced/refinished and quite a few lessons were learned that I plan on documenting here soon.

Anyway, to catch things up to when the car finally became ready to swap:
I'm still struggling to diagnose an intermittent long crank, which I'm thinking is the result of the shoddy Chinese main fuel pump that whines incessantly. Quite a few issues were fixed that helped made it less frequent but that's about all that is left. Do88 vacuum hose in black replaced all the crumbly original stuff (a big improvement in idle quality), the throttle switch was adjusted, and the car turned out to have a rather dubious power stage installed:

RG6iAizl.jpg


vjXHisel.jpg


This was replaced with a Bosch unit. I also pulled the intake off to replace what I thought was a broken breather box, but turned out to simply be a breather box that was not really mounted to anything and as such pissed oil everywhere. While I had the intake off I cleaned the throttle body with Delco Top Engine Cleaner and replaced the manifold and TB gaskets with new Elring pieces. The car still idled fairly poorly, until my dad tipped me off to something. It turns out throttle blades wear out/end up out of adjustment. The car was seeing some 2-5% throttle all the time instead of only the air from the IAC valve (which I also cleaned up with the same stuff). Resetting the throttle blade properly finally resolved my idle issues.

I'm doing something to the car almost daily now, which is awesome. I feel pretty good about how far it has come since I started, and it's only going to get better from here.

Oh, and some silly data I took for fun:

Sound level, constant 70 MPH: 73.9 dB (avg)

50-70 MPH, 5th gear (~13 psi, 13C, M90, stock exhaust):

Trial 1: 5.23 s (I think I jumped the gun here, hand timing isn't very good)
Trial 2: 5.99 s (probably most accurate?)
Trial 3: 7.22 s (started a few MPH short)
Average: 6.14 s

I need to revisit this and maybe revise my testing methods.

I think in-gear acceleration is a good "real-world" measurement for this car's use case, it's a street car that is usable on track and not the other way around.

KhKp18tl.jpg


Side note: I'm trying to be pretty thorough about documenting everything I do with the car, partially because it's fun and partially because I think it's a pretty useful skill to have. The black binder has all my receipts (yikes) and the green binder, as you would expect from the cover, has the 940/960/850 data pocket printed out because it's super handy.
 
Last edited:

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
Another fun thing about this car is that the kid who owned it before me had the eBay manual boost controller plumbed into the line for the CBV.
 

DET17

Reformed SAABaholic
Joined
Nov 1, 2009
Location
NW Georgia
Nice work young man; GLW the Engineering schooling!

You will find plenty of "sins of the past" when you begin stage Zero'ing these old Swedes..... plus a bit of wear related issues.

My son who owns a pair of 240s, just bought his GF a 93 940 NA..... and once he replaced the blown front struts they were both amazed at the ride quality of the 9 vs. the 2. These machines really shine on the highway. I'll be following your progress.......
 

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
Nice work young man; GLW the Engineering schooling!

You will find plenty of "sins of the past" when you begin stage Zero'ing these old Swedes..... plus a bit of wear related issues.

My son who owns a pair of 240s, just bought his GF a 93 940 NA..... and once he replaced the blown front struts they were both amazed at the ride quality of the 9 vs. the 2. These machines really shine on the highway. I'll be following your progress.......

Thank you very much! I've been following your thread, your attention to detail is very impressive. Jumping ahead a little bit, but I recently scored a set of near-new Bilstein Touring shocks from the junkyard ($14, woohoo) to replace the extremely crusty KYB Gas-a-Justs that were in there before and the difference in composure is astounding. I'm looking forward to doing the struts now for sure. Replacing the blown out bushings should work wonders as well, and while the car was in the air for the M90 swap I put a set of new Lesjofors HD springs in the rear to replace the leaning original ones.

You will have many more smiles with three pedals. It really makes the 7/9 series enjoyable to drive.

I've been following your thread, too! The car really is a blast with the M90, it's already been worth my while several times over. A manual transmission swap and a little extra boost really turned it from an old taxi into a proper enthusiast's car.

The most pressing issues at present are probably suspension (bushings/strut inserts), front brakes (the pedal is a little long and it's all pretty questionable up front in terms of rotors/pads/calipers/maybe even lines) and lately, getting the A/C to work thanks to our recent heat wave. Power is certainly acceptable now that I added some boost so I don't need to think about going faster for a little bit.

I have a GFB G-Force 2 that I'll do a little review of eventually that is set to about 13 psi at most. Wastegate pressure was baselined at a maximum of 5.8 psi, is that an indication of poor health somewhere or just worn out components? This car is the only turbo experience I have, for the most part, so I don't know how sensitive a lot of this stuff is to age/neglect other than that I keep tearing CBVs. I'm extremely happy with the results of the added boost, the car feels sooo much faster and finally feels turbocharged to boot. There's a ton of usable torque. I chose 13 psi as my boost level after looking at a 13C compressor map, considering that I have a stock intercooler that I have not looked at or cleaned, and noting that 13 psi was the most that the factory Turbo+ kit allowed for. As an added precaution I run 93 octane in this car. I could certainly push it more, but this is enough for now.

I think the A/C worked recently, as the compressor turns freely but one of the lines that runs off of the compressor is split in two. My guess is that this is from the same incident that destroyed the plastic belly pan and bent its mounts. I can't find my pictures now for some reason but I threw a new cheap aftermarket belly pan on there immediately after the swap was done. Seeing as the Volvo piece was an order of magnitude pricier and the only job of the belly pan (or "air guide" as the parts catalog calls it) is to be approximately the shape that it is I decided it would be a fine piece to cheap out on. The mounting tabs were bent back into shape with a pair of vice grips and a cloth to prevent any damage to paint/undercoating.
 
Last edited:

DET17

Reformed SAABaholic
Joined
Nov 1, 2009
Location
NW Georgia
If you start to restore the AC, consider an alternate top suction hose from the receiver/drier to the compressor. I tried at least 3 aftermarket 4 Seasons style tube/hoses to fit my 92 compressor.... none would fit, one even broke the end of my compressor while I tried to pull it into position with the mounting bolts (do NOT do this). I got an excellent tip from VOLUPARTS in the ATL. There is an early 7 series suction hose that rolls backward to the firewall, across the top of the rear valve cover, then dives behind your throttle body down to the compressor. I was a skeptic.... but now fully agree with this swap. Much cleaner and no Chinese bent tubing which won't fit your compressor. I think the 93 has the same unit as my 92.... but the 94-95 use the "rabbit ears" later compressor and the suction hoses are different (2ManyTurbos is an expert of the threads used on all these vintage compressors and he can fill you in). The high pressure hoses (aftermarket) fit just fine. My 92 still uses the R12 style condenser, and perhaps at 94 they switched to the parallel flow unit. Based on my experience, you do NOT need the parallel flow condenser with R134a so long as you use a variable orifice tube. Again, I was skeptical as these were near $40 compared to $5 for the fixed orifice, but after driving it in the steamy SE there is a significant difference in the temps coming out of the center duct.

If you proceed with your AC repairs, shoot me a PM for more 411. ;-)
 

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
Zj41oAfl.png


Polished the car, with some simple polishing compound on a foam pad attached to a drill with adapter. I'm very happy with how it came out. I wouldn't do anything more aggressive than what I did as the paint on the top surfaces is totally done for. Later tonight I'll run through my list of receipts and break down what I've done and forgotten to take pictures of before I move on to documenting the M90 swap, which I have about 2000 miles on and have been thoroughly enjoying.

If you start to restore the AC, consider an alternate top suction hose from the receiver/drier to the compressor. I tried at least 3 aftermarket 4 Seasons style tube/hoses to fit my 92 compressor.... none would fit, one even broke the end of my compressor while I tried to pull it into position with the mounting bolts (do NOT do this). I got an excellent tip from VOLUPARTS in the ATL. There is an early 7 series suction hose that rolls backward to the firewall, across the top of the rear valve cover, then dives behind your throttle body down to the compressor. I was a skeptic.... but now fully agree with this swap. Much cleaner and no Chinese bent tubing which won't fit your compressor. I think the 93 has the same unit as my 92.... but the 94-95 use the "rabbit ears" later compressor and the suction hoses are different (2ManyTurbos is an expert of the threads used on all these vintage compressors and he can fill you in). The high pressure hoses (aftermarket) fit just fine. My 92 still uses the R12 style condenser, and perhaps at 94 they switched to the parallel flow unit. Based on my experience, you do NOT need the parallel flow condenser with R134a so long as you use a variable orifice tube. Again, I was skeptical as these were near $40 compared to $5 for the fixed orifice, but after driving it in the steamy SE there is a significant difference in the temps coming out of the center duct.

If you proceed with your AC repairs, shoot me a PM for more 411.

Unfortunately my 93 seems to have the later style compressor. I pilfered an OE suction hose off of a very well maintained 94 940, a new OE Volvo compressor belt, and a new o-ring kit. Getting the hose in was difficult but with the car jacked up I was able to finagle it in there. I pre-oiled the o-rings with PAG oil just in case, but missed a few (oops) and didn't change the orifice tube which had been exposed to the elements for who knows how long. A proper vacuum and recharge (perks of working at a dealership) resulted in a brief amount of functional A/C but it seems to have a catastrophic leak somewhere. I don't see any grime on the condenser as if it had been leaking oil, so perhaps it is in the evaporator or one of the o-rings I missed? On the plus side the compressor does turn and doesn't make any odd noises. This particular subsystem of the car (cars in general, really) is pretty much completely foreign to me so any help is appreciated.
 
Last edited:

whatshouldido

Member
Joined
Mar 4, 2013
Location
Florida
Congratz! Very cool to see the m90 in the car looking forward to the guide! The m47 in my 240+t really made it fun my 91 745t is in need of 3!

These older gen redblock cars I wonder if you can drive em faster easier ?

Cheers to the work youv done!
 

DET17

Reformed SAABaholic
Joined
Nov 1, 2009
Location
NW Georgia
Unfortunately my 93 seems to have the later style compressor. I pilfered an OE suction hose off of a very well maintained 94 940, a new OE Volvo compressor belt, and a new o-ring kit. Getting the hose in was difficult but with the car jacked up I was able to finagle it in there. I pre-oiled the o-rings with PAG oil just in case, but missed a few (oops) and didn't change the orifice tube which had been exposed to the elements for who knows how long. A proper vacuum and recharge (perks of working at a dealership) resulted in a brief amount of functional A/C but it seems to have a catastrophic leak somewhere. I don't see any grime on the condenser as if it had been leaking oil, so perhaps it is in the evaporator or one of the o-rings I missed? On the plus side the compressor does turn and doesn't make any odd noises. This particular subsystem of the car (cars in general, really) is pretty much completely foreign to me so any help is appreciated.

Most likely the leak will be found in your condenser, as this is where the "high pressure" lives.

Did you dealership check pull a full vacuum on the car, and how long did you hold it? Bare minimum of 15 minutes, and I like 30 better. A good leak free system won't budge the vacuum needle in that period of time.

If a prior compressor died, then the metal shrapnel will be inside you condenser, and ultimately in the orifice tube (game over). Lucky for you the Taiwan replacements are just over $100. I would not suspect any issues with your evaporator, as that is the low pressure side.
 

redblockpowered

mails files to people
Joined
May 5, 2015
Location
Swampscott, MA
Most likely the leak will be found in your condenser, as this is where the "high pressure" lives.

Did you dealership check pull a full vacuum on the car, and how long did you hold it? Bare minimum of 15 minutes, and I like 30 better. A good leak free system won't budge the vacuum needle in that period of time.

If a prior compressor died, then the metal shrapnel will be inside you condenser, and ultimately in the orifice tube (game over). Lucky for you the Taiwan replacements are just over $100. I would not suspect any issues with your evaporator, as that is the low pressure side.

I know a full vacuum was pulled, but not for very long since this was done for free as a favor. I have an orifice tube to put in but motivation to repair the A/C has dwindled since things have been cooling down up here.

I recently lost the odometer of this car at 183k miles, unfortunately. Disassembly revealed a very burnt PCB (conducts electricity, often to places where it should not go) on the speedometer, likely due to capacitor failure. I tried twice to repair it but failed both times. I think one of the proprietary ICs in the board broke after the cap failure and caused the failure. I can't seem to find a replacement so I've purchased another cluster from 2manyturbos here on the board. I'll keep the other one around in the meantime in case I figure out a repair method.

I raced the car in August with the New England Region SCCA. I had a great time and found it to be effective as a diagnostic tool for both car and driver. I'd like to work on the car's initial turn-in, likely by way of larger front sway bar before I move on to stiffer springs. It left a lot to be desired in front-end grip and overall balance relative to the 240 chassis I am used to but I feel confident that I can do a reasonable job rectifying that. My back of the envelope math seems to indicate that the front wheel rate is about half what it's supposed to be to be "balanced" with the rear rate, so I'll have to see what I can do to (incrementally) add front roll stiffness. After autocross I changed out the control rod bushings for the cop/taxi/ambulance bushings, replacing the likely original ones that had to be removed with fire, a chisel, and a wire wheel. It feels smoother in transition now most notably although there are still more bushings to change.

If you want to watch a stock 940 plow around, video of my second and third passes can be found here: https://www.youtube.com/watch?v=bUJwcZ2IYI0

In addition, some catching up. Here are the minor jobs that I did and didn't take pictures of because they were pretty trivial:
Front seatbelt buttons
HD rear springs (measured to be the same wire diameter as wagon springs)
Plugs, cap and rotor (head mounted distributor caps are pricey yikes)
PCV breather box/oil trap/intake gasket
Driveshaft center bearing and support (with trans swap)
Driveshaft giubo (see above)
Reverse light switch (see above)
Rear main seal (see above)
Parking brake shoes/axle cables (was metal on metal before)
Oil cap gasket
Horn terminals, with very useful Volvo patch wiring kit
Valve adjustment
Oil pan gasket
Belly pan
Retorqued rattling factory exhaust
CHMSL cover (only available new in gray, replacing a black one for my black interior but it seems like the rear seatbelt mount shelf thing was gray anyway so I'm not going to sweat it)

This all either came from Volvo or OE suppliers depending on price difference, except for the belly pan which I bought aftermarket because I couldn't justify 10x the price for a part whose only job is to have a somewhat specific shape and not fall off.
 
Last edited:
Top