• Hello Guest, welcome to the initial stages of our new platform!
    You can find some additional information about where we are in the process of migrating the board and setting up our new software here

    Thank you for being a part of our community!

Temperature Dependent Base Boost Level. Help!

740Weapon

Traitor
Joined
Aug 2, 2004
Location
Salem MA
Help! I'm Stumped.

19t or 15g turbo, 15g wastegate actuator (Very solidly attached) B230FT, Greddy profec-B.

I have had a nagging problem for YEARS where on the street i can obtain up to 20 psi of boost controllably but at the strip i cant muster more than about 15 psi even with the EBC set to stay open (100% duty cycle).

I finnally got a new piece of info: when the motor is not super-hot my base WG setting is 10 psi. however when the motor is really hot the base setting reduces to about 7 psi.

what could be causing this?

i calculated that the WG rod length changes about 0.5 mm assuming it becomes 580 degrees F. (mixed units for the confusion factor). so I assume that thermal expasion isn't the main cause. (could be wrong)

The the WG spring could become weak with temp or something? Anyone else have this issue?

I think I'm going to switch to the 19t actuator and re-fab the bracket. (does that actuator have a higher base boost pressure?)

-Dana
 
first is your stock boost rly hooked up by you saying u ge this much im thinking no but i could be wrong cheek that then i would look for a better actuator if it is . get one that is has a stock setting of 16-18 psi there about 60 bucks brand new . or go the OG way and get a external waste gate and bov and that should take care of your problem
 
its not only the wastegate rod that expands...the temperature has an influence on the spring,diafragm, bracket and valve aswell.

cracks around the wastegate hole, and in the exhaust manifold can cause this boostproblem too, when the casting gets hot enough you loose exhaust pressure through the cracks, which has the same effect as opening the wastegate slighty.

if you can go external wastegate that would be good
 
I never had any issues like that on my super60-TD04HL setup with a newer T3 actuator.

If anything with my holset now I get almost 2psi more on a hot engine vs cold

A good actutor might just fix that Issue as the stock actuator as these things age seems to always cause some odd issues
 
its not only the wastegate rod that expands...the temperature has an influence on the spring,diafragm, bracket and valve aswell.

cracks around the wastegate hole, and in the exhaust manifold can cause this boostproblem too, when the casting gets hot enough you loose exhaust pressure through the cracks, which has the same effect as opening the wastegate slighty.

if you can go external wastegate that would be good

intersting point. the housing has a known big friggen crack... but once mike makes me an exhaust im changing housings... so i wont take it off just yet.
 
Back
Top